"Unable to save changes" message in google photos. Android phone | Photos | Forums: Ask the Geeks!

Please ask your questions here (not in email) – we promise to respond here, no such promise with email. This is a benefit of membership. Here’s info  on how to post to this Q&A Forum.

You must be logged in as a Premium Member to Ask the Geeks a question. All are welcome to freely browse the Forums.

Avatar
Lost password?
Advanced Search
Forum Scope


Match



Forum Options



Minimum search word length is 3 characters - maximum search word length is 84 characters
sp_TopicIcon
"Unable to save changes" message in google photos. Android phone
June 30, 2020
11:37 am
Avatar
kolbe smith
Member
Members
Forum Posts: 7
Member Since:
April 5, 2017
sp_UserOfflineSmall Offline

I keep getting a cannot save changes to Google photos. This is.new. android phone.

June 30, 2020
5:02 pm
Avatar
MrsGeek
Admin
Forum Posts: 3002
Member Since:
July 2, 2010
sp_UserOfflineSmall Offline

I assume you mean after editing? That you can’t save the edits? 

I’ll bet your camera is set to store photos on an SD card? There is a permissions issue that Google Photos doesn’t get permission to write to the SD card, it seems to be a problem after most every update. See this thread in the Google Photos support forum. 

Until a fix is found there are 2 workarounds

  1. Do your editing on the computer
  2. After editing on the phone, tap the 3-dot menu and Save a copy
July 1, 2020
11:13 am
Avatar
MrsGeek
Admin
Forum Posts: 3002
Member Since:
July 2, 2010
sp_UserOfflineSmall Offline

OR … you can do what I do and change the camera setting to store photos using internal memory rather than the sd card. If your phone is getting full, you can use Google Photos Free Up Space command to delete the local copy of photos.

July 1, 2020
2:19 pm
Avatar
MrsGeek
Admin
Forum Posts: 3002
Member Since:
July 2, 2010
sp_UserOfflineSmall Offline

I think I’ve found the fix.

  1. Open Google Photos
  2. tap the Account button – top right and choose Photos Settings
  3. scroll down till you see “SD Card Access” and select it
  4. The next screen gives you some steps, but if you tap on “Get Started” it takes you straight to the last step
  5. ALLOW – Allow access to SD card …

Let me know if this works for you. I feel a video coming on!

Forum Timezone: America/New_York
Most Users Ever Online: 301
Currently Online:
Guest(s) 18
Currently Browsing this Page:
1 Guest(s)
Top Posters:
THOMAS J PARKS: 163
Roxie Marston: 118
Barbara Dalderis: 108
Bob Brown: 96
David Cross: 89
guppy1: 81
Member Stats:
Guest Posters: 402
Members: 1198
Moderators: 1
Admins: 4
Forum Stats:
Groups: 3
Forums: 19
Topics: 2177
Posts: 7235
Newest Members:
Elizabeth Ross, Norris Battin, Bernie Weiss, Rick, Sherry Chadwick, UWP Student
Moderators: Jim Guld: 0
Administrators: MrGeek: 430, MrsGeek: 3002, Craig Biles: 0, David Carr: 1