Un-Delete Albums in Google Photos | Photos | Forums: Ask the Geeks!

Please ask your questions here (not in email) – we promise to respond here, no such promise with email. This is a benefit of membership. Here’s info  on how to post to this Q&A Forum.

You must be logged in as a Premium Member to Ask the Geeks a question. All are welcome to freely browse the Forums.

Avatar
Lost password?
Advanced Search
Forum Scope


Match



Forum Options



Minimum search word length is 3 characters - maximum search word length is 84 characters
sp_TopicIcon
Un-Delete Albums in Google Photos
May 24, 2016
9:29 am
Avatar
Fred Hagedorn
Member
Members
Forum Posts: 55
Member Since:
July 13, 2010
sp_UserOfflineSmall Offline

I made a mistake and deleted several “Albums” from my google photo’s account.

I still have the photo’s on the Photo’s page, and when I click on them to “Add to Album” I create a new album because the old album no longer shows. 

Google photo’s seems to create the album and lets me view it. But when I click the back arrow in the upper left to go back to the albums page the album I just created is not there. 

I’m at a loss on how to restore these albums. 

Thank you for any help you can give me.

May 24, 2016
5:32 pm
Avatar
MrsGeek
Admin
Forum Posts: 2806
Member Since:
July 2, 2010
sp_UserOfflineSmall Offline

So, are you saying that you started from scratch and re-created the albums, and they’re still not there?

If so, I can’t explain that. That would be my solution for deleted albums – is to re-create them. Did you try a refresh maybe? 

If perchance they were auto-created albums, there is one thing you can try … on a computer at Photos.Google.com open the Assistant and scroll to the bottom – there you’ll see “Unsaved Creations” if the albums are in there, you can find them and Save to Library.

Other than that, you could clear your browser cache? Reboot? and try again. Recreating the albums is the thing to do.

Do you have Picasa and the same pictures on your computer? Maybe use Picasa to make the albums.

May 25, 2016
6:43 pm
Avatar
Fred Hagedorn
Member
Members
Forum Posts: 55
Member Since:
July 13, 2010
sp_UserOfflineSmall Offline

I signed in this morning to Google Photo’s and the albums were still not showing. I did the computer shut down and re-start to no avail. Then I cleared out the history from the Chrome browser, still to no avail.

I actually had albums labeled by year, going back to 1919. Worked my way up to the mid ’70’s. Thousands of photo’s! Then I found something I was doing that didn’t fancy me, so I started “deleting” the albums up to 1970. Re-working on my photo’s from 1919, I then re-uploaded them. Then clicked on “add to album”. I named the new album 1919. Clicked on “view the album” and it showed me exactly what I was looking for, the photo’s arranged in order of when they were taken in that year. I was happy, so I clicked on the arrow in the upper left of the screen to go back to the album page. I was then expecting to see the 1919 album below the 1970 album, but it was no where in sight! I tried the next batch of 1920 photo’s, added them to a 1920 album. Went back to the album page expecting to see the newly created 1920 album, but again, not there.

Finally I clicked on the “Send Feedback” to Google and tried to explain what was going on. All day I’ve been thinking of what to do now. I hated the thought of opening another google email account and start all over. 

This evening I turned the computer back on, signed in to my google account, went to photo’s, and to my surprise all the albums are back on and in order! Thank You Google! I believe they must have re-set my account or something. I didn’t get any email explaining what happened and that they fixed it. 

I’ve learned my lesson, what ever it was, and I’ll be super careful “NOT” to delete any more albums. 

Thank You Chris for your suggestions. Hopefully someone can learn from my experience.

May 25, 2016
6:55 pm
Avatar
MrsGeek
Admin
Forum Posts: 2806
Member Since:
July 2, 2010
sp_UserOfflineSmall Offline

Whew!

Thanks for the update.

Forum Timezone: America/New_York
Most Users Ever Online: 93
Currently Online:
20
Guest(s)
Currently Browsing this Page:
1 Guest(s)
Top Posters:
THOMAS J PARKS: 149
Roxie Marston: 118
Barbara Dalderis: 103
Bob Brown: 96
David Cross: 89
guppy1: 75
Member Stats:
Guest Posters: 402
Members: 1063
Moderators: 1
Admins: 4
Forum Stats:
Groups: 3
Forums: 19
Topics: 2043
Posts: 6806
Newest Members:
Liz Milford, MaryJane Navarro, Joanne ODonnell, Charlie Lightner, Shirley Clark, John Roy
Moderators: Jim Guld: 0
Administrators: MrGeek: 424, MrsGeek: 2806, Craig Biles: 0, David Carr: 1