Blog--Compose--Extra spaces|Blogs|Forums: Ask the Geeks!|GeeksOnTour.COM

Please ask your questions here (not in email) – we promise to respond here, no such promise with email. This is a benefit of membership. Here’s info  on how to post to this Q&A Forum. If you need more help, you can book a 30 minute one-on-one Zoom meeting using our Office Hours feature.

You must be logged in as a Premium Member to Ask the Geeks a question. All are welcome to freely browse the Forums.

Avatar
Lost password?
Advanced Search
Forum Scope


Match



Forum Options



Minimum search word length is 3 characters - maximum search word length is 84 characters
sp_TopicIcon
Blog--Compose--Extra spaces
June 16, 2012
11:02 am
Avatar
Roxie Marston
Member
Members

Teachers
Forum Posts: 118
Member Since:
July 13, 2010
sp_UserOfflineSmall Offline

When I am composing a post the spacing between paragraphs or pictures is just fine.  When it gets published often there is a lot of empty space between paragraphs or pictures.  Returning to the post-compose page does not display this space. Has happened many times before. This just occured on the Maestro blog.  Need the web address.  Don’t think so.  Can you help me fix this?  Thanks…RoxieCry

June 16, 2012
8:32 pm
Avatar
MrsGeek
Admin
Forum Posts: 3418
Member Since:
July 2, 2010
sp_UserOfflineSmall Offline

Hey Roxie,

I have the same problem with Blogger.  The answer has to do with HTML code and how the Blogger post editor chooses to implement it.  We just type what we want and count on Blogger to write the underlying HTML, but it doesn’t handle paragraphs correctly, or consistently.  Over the years, they change which code to use, which changes the way the line spacing between paragraphs is handled.  

I think they should use <p> tags – that means paragraph and it handles the additional space between paragraphs well.  But, instead, Blogger uses <br /> tags, or <Div> or none at all, which seems to be their current preference.  If you look at my blog thru the years you will see all sorts of different spacing between paragraphs – yuk.

During the periods when I have used Windows Live Writer – my posts look much better because Live Writer appropriately uses <p> tags.

So, the best answer is – use Live Writer

If you want to stick with the Blogger’s native editor, then try changing the option (on the right side of the post editor) to:

Line Breaks -> Use <br> tag.  That will at least make your editor version match your published version.

Forum Timezone: America/New_York
Most Users Ever Online: 722
Currently Online:
Guest(s) 9
Currently Browsing this Page:
1 Guest(s)
Top Posters:
THOMAS J PARKS: 163
Roxie Marston: 118
Bob Brown: 96
James: 94
guppy1: 83
LuVerne Underhill: 79
Member Stats:
Guest Posters: 402
Members: 1335
Moderators: 1
Admins: 3
Forum Stats:
Groups: 3
Forums: 19
Topics: 2484
Posts: 8179
Newest Members:
Michael Friolet, Bruce Rives, Robert, Fermor Black, Lee McIntyre
Moderators: Jim: 0
Administrators: JimAdmin: 456, MrsGeek: 3418, David Carr: 1