Picasa problems after uploading to Windows 8 | Photos | Forums

 

Please ask your questions here (not in email) – we promise to respond here, no such promise with email.

Please consider registering
guest

Log In

Lost password?
Advanced Search

— Forum Scope —




— Match —





— Forum Options —





Minimum search word length is 4 characters - maximum search word length is 84 characters

Picasa problems after uploading to Windows 8
January 12, 2014
12:38 pm
Sue1707
Member
Forum Posts: 9
Member Since:
September 1, 2010
Offline

I am one VERY frustrated person.  I’ve upgraded to Windows 8 and now can’t seem to get Picasa to link to my blog.  When I try to upload photos, I get an empty screen that says “Service Unavailable.  Error 503″.  Does anyone else have this problem or is it just me?  I watched your video on getting rid of Google+ and returning to web albums.  I believe I have successfully done that but still can’t get anything to upload to my blog through Picasa.  

 

I’m scheduled to teach a class on Picasa this Thursday so I’m about to panic.  With my new Windows 8, it will be much harder to teach these classes as things will look much different to students from Windows 7 to 8.  Have you run into this problem yet?  How do you teach Picasa to both Windows 7 and 8 users?Cry  

January 13, 2014
11:20 am
MrsGeek
Admin
Forum Posts: 1534
Member Since:
July 2, 2010
Offline

We just tried the “Blog This” button on our windows 8 machine and it worked just fine.  There have been a few issues with recent updates to Picasa … make sure you are on the latest one by going to picasa.google.com and downloading it fresh.  

As for teaching Win 8 Picasa along with others, we’ve had Win 7, Win 8, and Macintosh in the same hands-on class.  Once they have Picasa open, everything works the same.  We didn’t have any problems.  The only thing that is different in 8 is how you open Picasa.  Although, actually, that is the same too, it just looks different.  In Win7 I usually click on the Start button and then simply type Picasa – it appears at the top of the list.  In Win8 you can do the same thing – click the Start icon in the lower left (or type the Windows logo key on your keyboard) and then type Picasa – the program will appear on a list and you click it to run.

You may want to download our Windows 8 seminar handout.

January 13, 2014
5:20 pm
MrsGeek
Admin
Forum Posts: 1534
Member Since:
July 2, 2010
Offline

From Sue1707:

Hi Chris–
Today the “Blog This” button works just fine.  Yesterday (all day!) I kept getting an error code that said Error 503….or something like that.  After doing more forum research, I found that many other folks ran into the same thing and their tech crew said they were working on the problem. Hallelujah….glad to hear it wasn’t just me.  All if fixed now…..and I got the Picasa Win7 & 8 thing figured out also.  Whew!  I’m still suffering from the shock of switching to 8.1.  Now I kinda like it.

Forum Timezone: America/New_York

Most Users Ever Online: 84

Currently Online:
8 Guest(s)

Currently Browsing this Page:
6 Guest(s)

Top Posters:

Bob Brown: 90

David Cross: 89

Barbara Dalderis: 86

Roxie Marston: 79

Bill Osborne: 59

S Allan Wilson: 55

Member Stats:

Guest Posters: 70

Members: 2847

Moderators: 3

Admins: 5

Forum Stats:

Groups: 3

Forums: 17

Topics: 1175

Posts: 3896

Newest Members: LaVerne Heinz, Jeanette Templeton, Cheri Peine, Debbie Davis

Moderators: Christine Guld: 0, Jim Guld: 0, rvnavigator: 9

Administrators: MrGeek: 318, MrsGeek: 1534, Via Email: 3, charlyleetham: 0, Craig Biles: 0

Powered by WishList Member - Membership Software